Jump to content

SuperRedSupra

Members
  • Content count

    3
  • Joined

  • Last visited

Community Reputation

0 Neutral

About SuperRedSupra

  • Rank
    Newbie

Profile Information

  • Gender
    Male
  • Location
    Florida
  • Real Name
    Nick
  1. Auto-transmission not shifting down from a stop

    Update: Transmission was way overfilled by a previous owner. I'll try to drain some of it out and hope for the best.
  2. Auto-transmission not shifting down from a stop

    I haven't checked the transmission fluid, no. Could oil pressure cause this maybe? I haven't experience it since I changed the engine oil and plugs.
  3. Auto-transmission not shifting down from a stop

    Didn't know where to ask this so I'm starting here First of all, I own an AT 89 supra turbo with the 7M engine, this generally only happens a couple minutes after I've gotten in the car and left for work/school. It happens rarely but it does happen and I'd like to know why and if I can fix it easily. So, basically, when I'm coming from a stop (usually at a stoplight after I've been sitting for a little while) I'll give the engine gas and it will build boost, but the car just barely crawls forward. It's almost like how in a manual transmission when you try to take off in 4th gear, lugging the engine really hard. Sometimes if I press the accelerator pedal all the way to the floor it will go (I guess it's shifting down but it happens so rarely and it's so weird that it's hard to tell if it's the transmission or something else). Was hoping this was a common issue or something because I can't even find a general car forum explaining what this is.
×